This project is read-only.

Cannot add SharpGL.WinForms Controls?

Sep 7, 2014 at 12:58 PM
Edited Sep 7, 2014 at 12:58 PM
Hello, everyone.
I'm new to this and wanted to use SharpGL.WinForms controls now. I've got everything added. SharpGL core and SharpGL.WinForms through NuGet Package. So, I went to the toolbox, clicked "Choose Items..." then on .NET Components I clicked "Browse" and browsed for the SharpGL.WinForms DLL: "SharpGL.WinForms.dll" When pressing okay, I get this error however:


I've also tried to change Target Platform from .NET Framework 4.0 Client Profile to .NET Framework 4.0 and still doesn't work.
Sep 7, 2014 at 5:42 PM
Is it possible that you have downloaded the assembly and it has been blocked by Windows?

Try navigating to the dll, right clicking on it and checking for an 'Unblock' option.
Sep 16, 2014 at 1:44 AM
Had a similar issue... not sure if it is the same or what, but perhaps this helps:
browse to the location where you have unpacked/stored the DLL files and right click on the SharpGL.dll file then select 'Properties'. On the first (General) page, you might find a 'Unblock' button under the 'Security' heading. Click that to unblock the DLL from working in VStudio. Do the same for the SharpGL.WinForms and SharpGL.SceneGraph (or whatever files you need). Then reload VS and see if that fixes the issue (did for me, was doing the WPF example in VS2010 with VB.NET).

@dwmkerr: thanks for the project, tutorial & samples... awesome job!
Sep 24, 2014 at 4:17 AM
@joeegar thanks for posting the tip and your comments!