This project is read-only.

OpenGL 4.3 support?

Jan 27, 2013 at 11:02 PM

Hey. It looks like SharpGL is 'only' supporting OpenGL 4.2
I would like to know if, and when OpenGL 4.3 comes to SharpGL.

We think about moving our whole engine to SharpGL since OpenTK is totally dead in development, and SharpGL seems to be a serious project.

Jan 28, 2013 at 8:34 AM

Hi,

SGL supports OpenGL 4.2 only at the moment. I am indeed planning to add support for OpenGL 4.3. However, before committing to moving your project, I'd recommend a trial against the SharpGL codebase if possible, to see how straightforward that would be :) Let me know if I can be of any help, SGL 2.1 will be released soon, I will try to put OGL 4.3 support on the roadmap for 2.2

Jan 28, 2013 at 8:33 PM

Sounds great! We will do some testing first but most things look very familiar :)

Thanks for the quick answer.

Jan 29, 2013 at 8:41 AM

No probs. Development has been slow lately due to other concerns, but things are moving again now. Trying to get a cel-shading pixel shader example finished to highlight some shader improvements and then the new version will be released. Last 5% of the work taking 95% of the time as usual!